Back to overview
Degraded
Chungus AI App is down
Sep 14 at 10:27am CEST
Affected services
Chungus AI App
Resolved
Sep 14 at 10:32am CEST
Chungus AI App recovered.
Affected services
Created
Sep 14 at 10:27am CEST
Chungus AI App is degraded.
Affected services