Back to overview
Degraded

Chungus AI App is down

Jul 22 at 09:53pm CEST
Affected services
Chungus AI App

Resolved
Jul 22 at 09:56pm CEST

Chungus AI App recovered.

Created
Jul 22 at 09:53pm CEST

Chungus AI App is degraded.